Jump to content

Can Not Place any bet as maximum stake shows only 0...!!!!!


Recommended Posts

Dear friends.

I can not bet at all. Anytime i try any kind of match single or combinations it will give me the below error message.

Stake too high

Sorry, the maximum allowed stake is €0.00.

Your betslip will be adjusted.

Letme know why this happens...???!! And how can be fixed..???

  • Like 1
Link to comment
Share on other sites


I had same problem. Tried to bet $CAD20 on 4 different games @ simple odds of around $2.00. Said "stake too high... will adjust accordingly". It lowered my stakes, I tried to execute bet ... same thing ... still "too high".

Not being able to bet CAD$20 on a simple single at odds around the 1/1 or $2.00 mark is ridiculous in the first place. The auto lowering and rejecting and lowering again of my stakes .... just a joke.

Tried online chat help - totally useless.

I am closing my UniBet account - a few hours after I opened it.

Find another bookmaker. These don't deserve my business.

  • Like 1
Link to comment
Share on other sites

  • 1 year later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...