Jump to content

Can't deposit even though account verified


yadavab
 Share

Go to solution Solved by RayL,

Recommended Posts

I could see options for depositing a few days ago, but now they're gone. When trying to depoisit I see the message:

OOPS!

You need to verify your account before you can make a deposit. It's easy to do so - please upload the required documents on the 'Verify Account' page in your account.

But I did submit a document and it was verified. On the verify document page it says "Thanks for verifying your account. You’re all ready to go – enjoy!".

Also, earlier when I tried to deposit with a visa and mastercard, I was unable to. It just said Sorry, something went wrong. Is it something with Unibet or with my bank?

 

Link to comment
Share on other sites

  • Solution

Hi @yadavab, welcome to the Community :)

The reason of the "Oops" was a block on the account that is automatically added after multiple failed deposit attempts. I can see that 3DS is a must when depositing so in case that this is not a feature that your bank has setup I'd recommend to contact them regarding the implementation of the 3DS process on your account. But long story short, the block is removed and you c an try again.

 

If you feel this answer was helpful, please feel free to click the "Accept as Solution" button on this comment.

 

/Ray

Former Community Moderator
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...