Jump to content

I can't make a deposit

Go to solution Solved by RayL,

Recommended Posts

When i need to put in the last 4 digits and the security code, i just get an error saying i put in the wrong details.
Well, i've tried for the last hour to delete and add the card again, everything seems perfect until the last step of the deposit.
What to do?

Link to comment
Share on other sites

  • Solution

Hi @Panex and welcome to the Community. I can see from the transaction history that the deposit is being declined by the bank and it;s tied to the security codes and that need to be implemented.

The CVV code on the back of your card (3 Numbers) And possibly 3D Secure code ( The SMS received from the bank with a security code that needs implementing in Unibet)

It might be worth contacting your bank on clarifying these details in order for them to allow the payment.

I can confirm that on our side there is nothing limiting your account.



  • Like 2
Former Community Moderator
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...