Jump to content

Unibet Social Media Freeroll


Recommended Posts

  • 1 month later...
  • 1 month later...

I don't see the password on Twitter for some reason? Tonight was Unibet Open freeroll, and I didn't find the pass from Twitter. I've scrolled the page all the way, but it's not there. And I also always press ctrl+F and search for "pass" etc, and I don't see it anywhere on the (UnibetPoker) page. Refreshing the page doesn't help either. Maybe this is a stupid Q, but where's the problem? How is the password supposed to show to me?


I'm new to Twitter, can it be, that I'm doing something wrong: Log in to Twitter, and check the UnibetPoker page/write it to the address bar. Also tried not logging and checking the page. Tried to unfollow and follow again, but the pass is not there. It can't be this freaking difficult, but I'd think that I'm not the only one facing this very problem so what to do? And I don't use Facebook.


Luckily I've got the pass by other means few times, i.e. tonight found it from twitch somehow(?) and once I asked my friend with FB account, but this is so frustrating, and stupid! I would never in a million years buy/pay one single product, that's been advertised/promoted this (complicated) way. This just applys in general. It makes me feel like the opposite. And I feel so stupid, searching some password to a game, that's right in front of me already, from all over the internet. And man has been to moon decades ago and everything :)


Well sure, it's not meant to be complicated and I believe, that I'm occurring something unusual here. I do understand Unibet acts like any corporation, that makes profit - promoting it's products and gaining followers. Well anyway ... :) If someone has faced the same problem, I'd be happy to hear, how to solve it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...